Cari Blog Ini

Selamat Tahun Baru 2010.............................................................................. Selamat datang di Gubuk Ilmu Gratis. Tempat di mana anda bisa mendapatkan referensi ilmu. Jika anda yang memiliki artikel yang ingin di tampilkan di sini anda bisa mengirimkannya ke gubig@telkom.net

Senin, 30 November 2009

Welcome to Our Free Zone of Knowledge 0 komentar

Senin, 30 November 2009 |
Thanks for surfing this blog. We will try our best to make this blog become better. Enjoy reading this blog. Hope that you can get more by viewing and reading our Elektronika Zone.
Cheers.^^

Rony Yang
Mechatronics Engineering
Politeknik Caltex Riau

My other blogs:
http://gogreen-health.blogspot.com
http://avr-programming.blogspot.com

read more

Konfigurasi Mikrotik pada PC router untuk gateway internet 2 komentar

Instalasi Sistem Operasi

Pada saat booting masuk ke setting BIOS. Kemudian pada setting boot sequences pilih pada first boot pada CD-ROM dan second pada IDE-0 [hdd]. Save settings kemudian restart [pastikan CD installer Mikrotik sudah ada di CD-ROM]. Booting dengan CD.


Saat booting kemudian masuk ke pilihan paket yg dapat diinstall.

Ilustrasinya sebagai berikut :
Welcome to MikroTik Router Software installation
Move around menu using 'p' and 'n' or arrow keys, select with 'spacebar'.
Select all with 'a', minimum with 'm'. Press 'i' to install locally or 'r' to
install remote router or 'q' to cancel and reboot.

[X] system         [ ] isdn         [ ] synchronous
[X] ppp            [ ] lcd          [ ] telephony
[X] dhcp           [ ] ntp          [ ] ups
[X] advanced-tools [ ] radiolan     [X] web-proxy
[ ] arlan          [ ] routerboard  [ ] wireless
[ ] gps            [X] routing
[X] hotspot        [X] security



untuk memilih paket tekan spasi pada saat menyorot.

Anda akan ditanyakan 2 hal :


Warning: all data on the disk will be erased!
Continue? [y/n]
[tekan Y]

Press [Y] to continue or [N] to abort the installation.
Do you want to keep old configuration? [y/n]:
[tekan Y]
You should choose whether you want to keep old configuration (press [Y])
or to erase the configuration permanently (press [N]) and continue without saving it.
For a fresh installation, press [N].
[ tekan Y jika ingin konfigurasi awal disimpan tekan N untuk fresh Install,disini saya lebih memilih N]
Creating partition...
Formatting disk...
The system will install selected packages.
After that you will be prompted to press 'Enter'.
Before doing that, remove the CD from your CD-Drive:
Software installed.
Press ENTER to reboot



Konfigurasi User

Setelah reboot kita bisa login. Gunakan nama : ADMIN dengan password : . Setelah masuk kita buat User Baru untuk menggantikan user admin.
[admin@mikrotik] > user add
Name : [isi nama user]
Group : full

Pilihan Group yang ada
full untuk admin
read untuk guest

Selanjutnya membuat password :
[admin@mikrotik] > user print

Akan tercetak daftar user
[admin@mikrotik] > user edit
number : 1 [ sesuai nomor urut user anda]
value-name : pass

ketikkan password anda, kemudian tekan ctrl+O kemudian disable user admin.
[admin@mikrotik] > user disable admin

untuk memeriksa apakah sudah disable ketik
[admin@mikrotik] >user pr

Jika user admin terdapat tanda X disebelah kiri maka sudah ter-disable.



Konfigurasi Interface

Selanjutnya, kita set interface :

Pertama kita check dulu interface terpasang.
[admin@mikrotik] > interface print

Untuk memudahkan dalam konfigurasi kita berikan nama unik untuk interface2 yg kita gunakan.
[admin@mikrotik] > interface edit
Number : 1
Value name : name

Ganti ether2 dengan eth2-lokal [ ini untuk interface ke local client 192.168.0.0/16]
Tekan Ctrl+O

kemudian lakukan langkah yg sama untuk ether3 dan 4 dengan nama eth3-ADSL [ke ADSL] dan eth4-servers[ke switch PC server].

Kemudian buat satu interface bridge baru [sebagai bridge IP public]
/interface bridge add name=serverbridge disabled=no
/interface bridge port add interface=eth3-ADSL bridge=serverbridge
/interface bridge port add interface=eth4-servers bridge=serverbridge



Pemberian IP Address



Ip address kita berikan pada interface gateway local dan bridge. Pemberian ip pada bridge interface tidak mutlak, pemberian ip ini hanya untukmemudahkan remote access dari luar.
/ip address print
/ip address add address=172.168.0.3/40 interface=serverbridge disabled=no
/ip address print
/ip address add address=192.168.0.254/16 interface=eth2-lokal disabled=no
/ip address print


Selanjutnya kita setting default gateway kita.
/ip route add gateway=172.168.0.3
/ip route print

Kemudian kita test ping ke gateway
/ping 222.124.23.41



Konfigurasi NAT (Network Address Translation)

NAT berfungsi untuk meneruskan paket dari ip local ke ip public (fungsi gateway router)
/ip firewall nat add chain=srcnat action=src-nat to-addresses=172.168.0.3 to-ports=0-65535 out-interface=serverbridge disabled=no
/ip firewall nat add chain=dstnat action=dst-nat to-addresses=172.168.0.6 to-addresses=172.168.0.6 to-addresses=172.168.0.6 to-ports=2011 dst-port=80 in-interface=eth2-local disabled=no


setting DNS
/ip dns set primary-dns=172.168.0.6 allow-remoterequests=yes
/ip dns set secondary-dns=202.134.1.10 allow-remoterequests=yes
/ip dns print


Kemudian tes ping ke nama domain ex: google.com

read more

SSL (Secure Socket Layer) 0 komentar

Teknologi enkripsi yang sering digunakan adalah Secure Socket Layer atau biasanya dikenal sebagai SSL. Digunakan di semua browser, SSL menggunakan public key crytography dan public key infrastructure (PKI) yang dipercaya untuk menjamin komunikasi data di web. Setiap kali anda berkunjung ke jaringan URL yang mulai dengan http, itu berarti anda sedang menggunakan SSL.

Implementasi SSL di dalam web browser termasuk sekumpulan sertifikat dari sumber yang dipercaya, yang dikenal sebagai certificate authorities (CA). Sertifikat ini adalah kunci cryptographic yang dipergunakan untuk mencek keaslian situs web. Jika anda melihat-lihat ke situs web yang menggunakan SSL, browser dan server terlebih dahulu bertukaran sertifikat. Browser memeriksa bahwa sertifikat yang disediakan oleh server sama dengan hostname DNS nya, bahwa sertifikat tersebut belum expired, dan bahwa ditandatangani oleh certificate authorities yang terpercaya. Server juga memeriksa identitas sertifikat browser. Jika surat keterangan diakui, browser dan server akan menegosiasikan kunci sesi master menggunakan sertifikat yang sudah dipertukarkan sebelumnya untuk melindunginya. Kunci itu kemudian dipergunakan untuk mengenkripsi semua komunikasi sampai browser selesai berkomunikasi. Enkapsulasi data seperti ini dikenal sebagai tunnel.


Gambar : Eavesdropper harus membuka enkripsi yang kuat untuk mengamati trafik di tunnel yang sudah di enkripsi. Percakapan di tunnel identik dengan percakapan yang tidak dienkripsi.

Penggunaan sertifikat dengan PKI tak hanya melindungi komunikasi dari Eavesdropper, tetapi juga mencegah apa yang dinamakan serangan man-in-the-middle (MITM). Di serangan man-in-the-middle, seorang user jahat intersep / menangkap semua komunikasi di antara browser dan server. Dengan memberikan sertifikat palsu baik ke browser maupun server, pemakai jahat bisa melakukan dua sesi yang dienkripsi sekaligus. Karena user jahat mengetahui rahasia kedua sambungan, sangat mudah untuk mengamati dan memanipulasi data yang diberikan di antara browser dan server.


Gambar : Man-in-the-middle secara efektif menguasai segalanya yang di lihat user, dan dapat merekam dan memanipulasi semua trafik. Tanpa infrastruktur kunci publik untuk mencek keaslian kunci, enkripsi kuat saja tidak bisa melindungi terhadap serangan seperti ini.


Penggunaan sertifikat dengan PKI tak hanya melindungi komunikasi dari Eavesdropper, tetapi juga mencegah apa yang dinamakan serangan man-in-the-middle (MITM). Di serangan man-in-the-middle, seorang user jahat intersep / menangkap semua komunikasi di antara browser dan server. Dengan memberikan sertifikat palsu baik ke browser maupun server, pemakai jahat bisa melakukan dua sesi yang dienkripsi sekaligus. Karena user jahat mengetahui rahasia kedua sambungan, sengat mudah untuk mengamati dan manipulasi data yang diberikan di antara server dan browser. 


Penggunaan PKI sangat baik untuk mencegah serangan seperti ini. Agar serangan berhasil, user jahat harus memberikan sertifikat kepada klien yang ditandatangani oleh certificate authorities terpercaya. Kecuali kalau CA sudah dijebol (walaupun sangat tak mungkin) atau user ditipu agar mau menerima sertifikat palsu, maka serangan seperti itu tidak mungkin. Oleh karenanya penting bagi user untuk tahu bahwa mengabaikan peringatan mengenai sertifikat yang sudah expire atau tidak layak sangat berbahaya, khususnya jika memakai jaringan nirkabel. Dengan mengklik tombol “ignore” saat di minta oleh browser mereka, user membuka diri mereka terhadap banyak kemungkinan serangan.

SSL tak hanya dipakai untuk web browsing. Protokol email yang tidak aman seperti IMAP, POP, dan SMTP dapat di amankan dengan membungkus mereka dengan tunnel SSL. Kebanyakan klien email modern mendukung IMAPS dan POPS (IMAP dan POP aman) dan juga SMTP yang dilindungi SSL/TLS. Jika server email anda tidak menyediakan bantuan SSL, anda masih bisa mendapatkannya dengan SSL memakai paket seperti Stunnel (http://www.stunnel.org/). SSL bisa dipergunakan untuk secara efektif untuk menjamin hampir semua servis mana pun yang jalan di TCP.

http://125.160.17.21/wiki/index.php/WNDW:_SSL

read more

Membuat Situs Social Networking Ala Facebook 0 komentar

Facebook ????? siapa yang tidak kenal dengan situs Social Networking yang satu ini. Berbagi informasi bukanlah menjadi sebuah hal yang sulit, termasuk berbagi foto, video, artikel, dan banyak lagi hal lain yang bisa dilakukan oleh situs ini.

Kita juga bisa membuat situs sejenis yang lebih sederhana namun tidak kalah bagusnya. Sebuah aplikasi Open Source memungkinkan kita untuk melakukannya. Aplikasi ini bernama Mahara sampai tulisan ini diterbitkan, Mahara telah sampai pada versi 1.2.0.

Aplikasi ini dikembangkan dengan bahasa PHP dan database yang digunakan adalah MySQL. Jadi, untuk mengembangkan aplikasi ini anda harus memiliki Web Server + MySQL Server + PHP.

Aplikasi Mahara dapat anda download di sini.


read more

Belajar Menjadi Hacker (klik-kanan.com) oleh Onno W. Purbo 0 komentar

Hacker dengan keahliannya dapat melihat & memperbaiki kelemahan perangkat lunak di komputer; biasanya kemudian di publikasikan secara terbuka di Internet agar sistem menjadi lebih baik. Sialnya, segelintir manusia berhati jahat menggunakan informasi tersebut untuk kejahatan - mereka biasanya disebut cracker. Pada dasarnya dunia hacker & cracker tidak berbeda dengan dunia seni, disini kita berbicara seni keamanan jaringan Internet.

Saya berharap ilmu keamanan jaringan di tulisan ini digunakan untuk hal-hal yang baik - jadilah Hacker bukan Cracker. Jangan sampai anda terkena karma karena menggunakan ilmu untuk merusak milik orang lain. Apalagi, pada saat ini kebutuhan akan hacker semakin bertambah di Indonesia dengan semakin banyak dotcommers yang ingin IPO di berbagai bursa saham. Nama baik & nilai sebuah dotcom bisa jatuh bahkan menjadi tidak berharga jika dotcom di bobol. Dalam kondisi ini, para hacker di harapkan bisa menjadi konsultan keamanan bagi para dotcommers tersebut - karena SDM pihak kepolisian & aparat keamanan Indonesia amat sangat lemah & menyedihkan di bidang Teknologi Informasi & Internet. Apa boleh buat cybersquad, cyberpatrol swasta barangkali perlu di budayakan untuk survival dotcommers Indonesia di Internet.


Berbagai teknik keamanan jaringan Internet dapat di peroleh secara mudah di Internet antara lain di http://www.sans.org, http://www.rootshell.com, http://www.linuxfirewall.org/, http://www.linuxdoc.org, http://www.cerias.purdue.edu/coast/firewalls/, http://www.redhat.com/mirrors/LDP/HOWTO/. Sebagian dari teknik ini berupa buku-buku yang jumlah-nya beberapa ratus halaman yang dapat di ambil secara cuma-cuma (gratis). Beberapa Frequently Asked Questions (FAQ) tentang keamanan jaringan bisa diperoleh di http://www.iss.net/vd/mail.html, http://www.v-one.com/documents/fw-faq.htm. Dan bagi para experimenter beberapa script / program yang sudah jadi dapat diperoleh antara lain di http://bastille-linux.sourceforge.net/, http://www.redhat.com/support/docs/tips/firewall/firewallservice.html.

Bagi pembaca yang ingin memperoleh ilmu tentang jaringan dapat di download secara cuma-cuma dari http://pandu.dhs.org, http://www.bogor.net/idkf/, http://louis.idaman.com/idkf. Beberapa buku berbentuk softcopy yang dapat di ambil gratis dapat di ambil dari http://pandu.dhs.org/Buku-Online/. Kita harus berterima kasih terutama kepada team Pandu yang dimotori oleh I Made Wiryana untuk ini. Pada saat ini, saya tidak terlalu tahu adanya tempat diskusi Indonesia yang aktif membahas teknik-teknik hacking ini - tetapi mungkin bisa sebagian di diskusikan di mailing list lanjut seperti kursus-linux@yahoogroups.com & linux-admin@linux.or.id yang di operasikan oleh Kelompok Pengguna Linux Indonesia (KPLI) http://www.kpli.or.id.

Cara paling sederhana untuk melihat kelemahan sistem adalah dengan cara mencari informasi dari berbagai vendor misalnya di http://www.sans.org/newlook/publications/roadmap.htm#3b tentang kelemahan dari sistem yang mereka buat sendiri. Di samping, memonitoring berbagai mailing list di Internet yang berkaitan dengan keamanan jaringan seperti dalam daftar http://www.sans.org/newlook/publications/roadmap.htm#3e.

Dijelaskan oleh Front-line Information Security Team, “Techniques Adopted By ‘System Crackers’ When Attempting To Break Into Corporate or Sensitive Private Networks,” fist@ns2.co.uk http://www.ns2.co.uk. Seorang Cracker umumnya pria usia 16-25 tahun. Berdasarkan statistik pengguna Internet di Indonesia maka sebetulnya mayoritas pengguna Internet di Indonesia adalah anak-anak muda pada usia ini juga. Memang usia ini adalah usia yang sangat ideal dalam menimba ilmu baru termasuk ilmu Internet, sangat disayangkan jika kita tidak berhasil menginternetkan ke 25000 sekolah Indonesia s/d tahun 2002 - karena tumpuan hari depan bangsa Indonesia berada di tangan anak-anak muda kita ini.

Nah, para cracker muda ini umumnya melakukan cracking untuk meningkatkan kemampuan / menggunakan sumber daya di jaringan untuk kepentingan sendiri. Umumnya para cracker adalah opportunis. Melihat kelemahan sistem dengan mejalankan program scanner. Setelah memperoleh akses root, cracker akan menginstall pintu belakang (backdoor) dan menutup semua kelemahan umum yang ada.

Seperti kita tahu, umumnya berbagai perusahaan / dotcommers akan menggunakan Internet untuk (1) hosting web server mereka, (2) komunikasi e-mail dan (3) memberikan akses web / internet kepada karyawan-nya. Pemisahan jaringan Internet dan IntraNet umumnya dilakukan dengan menggunakan teknik / software Firewall dan Proxy server. Melihat kondisi penggunaan di atas, kelemahan sistem umumnya dapat di tembus misalnya dengan menembus mailserver external / luar yang digunakan untuk memudahkan akses ke mail keluar dari perusahaan. Selain itu, dengan menggunakan agressive-SNMP scanner & program yang memaksa SNMP community string dapat mengubah sebuah router menjadi bridge (jembatan) yang kemudian dapat digunakan untuk batu loncatan untuk masuk ke dalam jaringan internal perusahaan (IntraNet).

Agar cracker terlindungi pada saat melakukan serangan, teknik cloacking (penyamaran) dilakukan dengan cara melompat dari mesin yang sebelumnya telah di compromised (ditaklukan) melalui program telnet atau rsh. Pada mesin perantara yang menggunakan Windows serangan dapat dilakukan dengan melompat dari program Wingate. Selain itu, melompat dapat dilakukan melalui perangkat proxy yang konfigurasinya kurang baik.

Setelah berhasil melompat dan memasuki sistem lain, cracker biasanya melakukan probing terhadap jaringan dan mengumpulkan informasi yang dibutuhkan. Hal ini dilakukan dengan beberapa cara, misalnya (1) menggunakan nslookup untuk menjalankan perintah ‘ls ’ , (2) melihat file HTML di webserver anda untuk mengidentifikasi mesin lainnya, (3) melihat berbagai dokumen di FTP server, (4) menghubungkan diri ke mail server dan menggunakan perintah ‘expn ’, dan (5) mem-finger user di mesin-mesin eksternal lainnya.

Langkah selanjutnya, cracker akan mengidentifikasi komponen jaringan yang dipercaya oleh system apa saja. Komponen jaringan tersebut biasanya mesin administrator dan server yang biasanya di anggap paling aman di jaringan. Start dengan check akses & eksport NFS ke berbagai direktori yang kritis seperti /usr/bin, /etc dan /home. Eksploitasi mesin melalui kelemahan Common Gateway Interface (CGI), dengan akses ke file /etc/hosts.allow.

Selanjutnya cracker harus mengidentifikasi komponen jaringan yang lemah dan bisa di taklukan. Cracker bisa mengunakan program di Linux seperti ADMhack, mscan, nmap dan banyak scanner kecil lainnya. Program seperti ‘ps’ & ‘netstat’ di buat trojan (ingat cerita kuda troya? dalam cerita klasik yunani kuno) untuk menyembunyikan proses scanning. Bagi cracker yang cukup advanced dapat mengunakan aggressive-SNMP scanning untuk men-scan peralatan dengan SNMP.

Setelah cracker berhasil mengidentifikasi komponen jaringan yang lemah dan bisa di taklukan, maka cracker akan menjalan program untuk menaklukan program daemon yang lemah di server. Program daemon adalah program di server yang biasanya berjalan di belakang layar (sebagai daemon / setan). Keberhasilan menaklukan program daemon ini akan memungkinkan seorang Cracker untuk memperoleh akses sebagai ‘root’ (administrator tertinggi di server).

Untuk menghilangkan jejak, seorang cracker biasanya melakukan operasi pembersihan ‘clean-up’ operation dengan cara membersihkan berbagai log file. Dan menambahkan program untuk masuk dari pintu belakang ‘backdooring’. Mengganti file .rhosts di /usr/bin untuk memudahkan akses ke mesin yang di taklukan melalui rsh & csh.

Selanjutnya seorang cracker dapat menggunakan mesin yang sudah ditaklukan untuk kepentingannya sendiri, misalnya mengambil informasi sensitif yang seharusnya tidak dibacanya; mengcracking mesin lain dengan melompat dari mesin yang di taklukan; memasang sniffer untuk melihat / mencatat berbagai trafik / komunikasi yang lewat; bahkan bisa mematikan sistem / jaringan dengan cara menjalankan perintah ‘rm -rf / &’. Yang terakhir akan sangat fatal akibatnya karena sistem akan hancur sama sekali, terutama jika semua software di letakan di harddisk. Proses re-install seluruh sistem harus di lakukan, akan memusingkan jika hal ini dilakukan di mesin-mesin yang menjalankan misi kritis.

Oleh karena itu semua mesin & router yang menjalankan misi kritis sebaiknya selalu di periksa keamanannya & di patch oleh software yang lebih baru. Backup menjadi penting sekali terutama pada mesin-mesin yang menjalankan misi kritis supaya terselamatkan dari ulah cracker yang men-disable sistem dengan ‘rm -rf / &’.

Bagi kita yang sehari-hari bergelut di Internet biasanya justru akan sangat menghargai keberadaan para hacker (bukan Cracker). Karena berkat para hacker-lah Internet ada dan dapat kita nikmati seperti sekarang ini, bahkan terus di perbaiki untuk menjadi sistem yang lebih baik lagi. Berbagai kelemahan sistem di perbaiki karena kepandaian rekan-rekan hacker yang sering kali mengerjakan perbaikan tsb. secara sukarela karena hobby-nya. Apalagi seringkali hasil hacking-nya di sebarkan secara cuma-cuma di Internet untuk keperluan masyarakat Internet. Sebuah nilai & budaya gotong royong yang mulia justru tumbuh di dunia maya Internet yang biasanya terkesan futuristik dan jauh dari rasa sosial.

Pengembangan para hobbiest hacker ini menjadi penting sekali untuk keberlangsungan / survival dotcommers di wahana Internet Indonesia. Sebagai salah satu bentuk nyatanya, dalam waktu dekat Insya Allah sekitar pertengahan April 2001 akan di adakan hacking competition di Internet untuk membobol sebuah server yang telah di tentukan terlebih dahulu. Hacking competition tersebut di motori oleh anak-anak muda di Kelompok Pengguna Linux Indonesia (KPLI) Semarang yang digerakan oleh anak muda seperti Kresno Aji (masaji@telkom.net), Agus Hartanto (hartx@writeme.com) & Lekso Budi Handoko (handoko@riset.dinus.ac.id). Seperti umumnya anak-anak muda lainnya, mereka umumnya bermodal cekak - bantuan & sponsor tentunya akan sangat bermanfaat dan dinantikan oleh rekan-rekan muda ini.

Mudah-mudahan semua ini akan menambah semangat pembaca, khususnya pembaca muda, untuk bergerak di dunia hacker yang mengasyikan dan menantang. Kalau kata Captain Jean Luc Picard di Film Startrek Next Generation, “To boldly go where no one has gone before”.

Penulis: Onno W Purbo

read more

Sabtu, 28 November 2009

AJAX 0 komentar

Sabtu, 28 November 2009 |
Perkenalan

AJAX (Asynchronous JavaScript and XML) bukanlah merupakan sebuah bahasa pemrograman web yang baru, lalu apakah AJAX itu ??????

AJAX adalah teknik pemrograman web baru yang mampu melakukan pertukaran data dengan server di belakang layar, sehingga halaman web tidak harus dibaca ulang secara keseluruhan setiap kali seorang pengguna melakukan perubahan. Hal ini akan meningkatkan interaktivitas, kecepatan, dan usability. Saat ini, hampir semua browser memiliki kemampuan dukungan terhadap AJAX.



Memulai AJAX

Pada teknik pemrograman web yang lama untuk mengirimkan data ke server, halaman web harus memuat form dan kemudian form tersebut di submit, menunggu respon dari server, dan kemudian halaman hasil akan ditampilkan sebagai sebuah halaman baru, hal ini menyebabkan aplikasi web berjalan lambat dan kurang user friendly.

Dengan AJAX, JavaScript akan berkomunikasi dengan server melalui sebuah object yang dinamakan sebagagai XMLHttpRequest. Dengan object ini halaman web bisa melakukan request dan menerima respon tanpa harus memuat ulang halaman web itu sendiri.

Di dalam AJAX dikenal istilah readyState. Properti readyState menyimpan status respon server. Setiap terjadi perubahan pada properti readyState, fungsi onreadystatechange akan dieksekusi.

Berikut adalah properti readyState beserta penjelasannya
0 = Request belum terinisialisasi
1 = Request telah di set up
2 = Request telah terkirim
3 = Request sedang dalam proses
4 = Request lengkap (Complete)


Contoh Aplikasi AJAX

Lalu bagaimakah cara menggunakan AJAX ?? di bawah ini disertakan sebuah contoh aplikasi AJAX sederhana dengan bahasa pemrograman web ASP namun bukan berarti anda tidak bisa menggunakan bahasa pemrograman web yang lain.




read more
Related Posts with Thumbnails

Tentang Gubuk Ilmu Gratis

Blog ini dibuat dengan tujuan agar dapat menjadi tempat berbagi ilmu dengan teman-teman di Indonesia. Kami berharap dengan hadirnya blog ini bisa memudahkan teman-teman untuk mendapatkan referensi ilmu.

Donasi

Jika anda merasa bahwa blog ini berguna dan anda ingin menyumbangkan sedikit dana untuk blog ini klik tombol di bawah

Silahkan Pilih Kategori


Saran Untuk Gubuk Ilmu

Untuk mengembangkan blog ini agar lebih berguna untuk kita semua, saya (Edi Wang) dan tim Gubuk Ilmu Gratis sangat mengharapkan kritik dan saran dari anda dan tentunya yang bersifat membangun.

Daftar Penulis

1. Ardianto Wibowo lihat profil
2. Dadang Iqwandy lihat profil
3. Edi Susanto (Edi Wang) lihat profil
4. Nico Gunawan lihat profil
5. Rony (Rony Yang) lihat profil
6. Yuli Fitrisia lihat profil
7. Anton Siswanto lihat profil

Status IM Penulis

Status Penulis
EDI WANG
NICO GUNAWAN
RONY YANG
DADANG IQWANDY
ARDIANTO WIBOWO
ANTON SISWANTO
 

Facebook Blog Founder

Follow Me

Ada kesalahan di dalam gadget ini

Statistik

Anda Pengunjung ke :

Jumlah Pengunjung Online :
Copyleft © Gubuk Ilmu Gratis